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LINK UTILI

https://docs.qgis.org/3.10/it/docs/gentle_gis_introduction/
https://rsdi.regione.basilicata.it/dbgt-ctr/

http://dati.regione.basilicata.it/catalog/dataset
https://vertical-srl.it/openlayer-ggis/

https://docs.qgis.org/3.10/it/docs/gentle_gis_introduction/raster data.h
tml#georeferencing

Compositore di Stampa

https://www.youtube.com/watch?v=CnSffyLOL7c

https://www.youtube.com/watch?v=0PzvSTreOuQ



GEOREFERENZIAZIONE

LA GEOREFERENZIAZIONE CONSISTE NEL POSIZIONARE,
MEDIANTE PUNTI A COORDINATE NOTE (DETTI ANCHE
PUNTI DI CONTROLLO O TIC - PUNTI DI REGISTRAZIONE
DELLA CARTOGRAFIA DI CUlI SI  CONOSCE LA
CORRISPONDENTE POSIZIONE SUL TERRENO) DATI
VETTORIALI O UN IMMAGINE RASTER NELLA RISPETTIVA
ZONA DEL TERRITORIO REALE SECONDO UN
DETERMINATO SISTEMA DI RIFERIMENTO.




? GEOREFERENZIAZIONE

GEOREFERIRE UN FILE (RASTER E\O VECTOR) SIGNIFICA ASSEGNARE
AD OGNI PUNTO DELLA CARTA DIGITALE LE COORDINATE ESATTE,
ESPRESSE NELLO STESSO SISTEMA DI RIFERIMENTO ADOTTATO PER LA
REALIZZAZIONE DELLA CARTA DI PARTENZA.

LA GEOREFERENZIAZIONE E FONDAMENTALE PER ASSOCIARE AD OGNI
PUNTO DELL'IMMAGINE LE SUE COORDINATE SPAZIALI REALI, AL FINE
DI POTER SOVRAPPORRE LA STESSA IMMAGINE CON ALTRI DATI
RELATIVI ALLO STESSO PUNTO DEL TERRITORIO CUI SI RIFERISCONO.



GEOREFERENZIAZIONE
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Matrice immagine nel sistema di
coordinate terreno (risultato)

O Q @) 0

Matrice immagine nel sistema di
coordinate camera (ornginale)
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FASI DELLA
GEOREFERENZIAZIONE

Scansione (trasformazione digitale di cartografia)
Importazione

Ritaglio

Inserimento punti di controllo

Scelta del modello

Controllo errori

Operazioni finali
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[Atach || chance || cancel |

Scelta della palette da utilizzare

(RGB-B\N)




RITAGLIO\MOSAICATURA
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PUNTI DI CONTROLLO

| Ele Edt Element Settings Tools Utities Workspace Window Help
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MODELLO DI GEOREFERENZIAZIONE:

Il modello e costituito da un set di funzioni matematiche atte a stabilire la
corrispondenza fra 1 punti di controllo, o meglio fra la geometria del punti
base e la geometria del corrispondenti punti da georiferire.

In pratica queste funzioni software identificano una corrispondenza fra I
diversi punti di controllo ed interpolano gli spazi che fra di essi esistono

| tipi di modelli presenti sono:
e Helmert

« Similitude

 Affine

* Projective

* Polynomial



MODELLO HELMERT

Tale modello ¢ anche detto “rigid body”, in quanto esegue

una rotazione e due traslazioni (X and Y), non effettuando
alcuna ‘““scalatura”.

Richiede almeno due punti di controllo.

!




MODELLO SIMILITUDE

Tale modello esegue una rotazione e due traslazioni (X and Y),
effettuando una “‘scalatura”, con un uguale fattore per entrambi
gliassi (X and Y).

Richiede almeno due punti di controllo.

2




MODELLO AFFINE

Il modello affine determina una rotazione e due traslazioni (X
and Y), applicando un diverso fattore di scala per I due assi
(X and Y), modificandone anche I’ortogonalita.

Richiede almeno tre punti di controllo.

4

+ +

L’utilizzo di questo modello e indicato quando bisogna
“registrare” un documento con piccole deformazioni (scanner
e/o carta).




MODELLO PROJECTIVE

Questo modello proietta un piano all’interno di un altro
piano.
Richiede almeno quattro punti di controllo.

- +

+ -

L’utilizzo di questo modello e indicato quando bisogna
“registrare” un documento non molto deformato (foto aerea
bassa quota).



MODELLO POLYNOMIAL 2E 3

Questi modelli sono utilizzati per “registrare” foto aeree che
non abbiano elevati dislivelli.
| punti minimi richiesti vanno da sei a dieci.

¥ ¥




RICAMPIONAMENTO

Il ricampionamento, o resampling, e un processo elaborativo in grado di
creare una nuova immagine, partendo da una immagine base, pixel per
pixel, adottando un appropriato valore dei pixel.

Tale elaborazione oltre a modificare la geometria dell’immagine € capace
di riassegnare 1l contenuto Informativo del pixel stesso (es. risposta
radiometrica).

Infatti e possibile assegnare un determinato valore informativo ad ogni
pixel mettendolo in relazione ai pixel del suo intorno.



RICAMPIONAMENTO

Nearest Neighbor; Interpolazione Bilineare; Convoluzione
Cubica

Nearest Neighbor: assegna al pixel in uscita il valore del pixel
piu vicino nell'immagine in input.

B e




RICAMPIONAMENTO

Nearest Neighbor; Interpolazione Bilineare;
Convoluzione Cubica

Interpolazione Bilineare: assegna al pixel in uscita un valore
dipendente dai 4 pixel piu vicini nell'immagine in input.




RICAMPIONAMENTO

Nearest  Neighbor; Interpolazione  Bilineare;
Convoluzione Cubica

Convoluzione Cubica: assegna al pixel in uscita un valore
dipendente dai 16 pixel piu vicini nell'immagine in input.
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PROCEDIMENTO

Molti progetti in ambito GIS richiedono la georeferenziazione di dati di tipo raster. Con
Il termine georeferenziazione ci si riferisce al processo mediante il quale si assegnano
delle coordinate del mondo reale a ciascun pixel del raster. Molte volte queste coordinate
si ottengono facendo ricerche sul campo - raccogliendo con dispositivi GPS le coordinate
di alcune geometrie facilmente identificabili nell’immagine o0 nelle carte. In determinati
casi, per esempio quando state cercando di trattare carte digitalizzate con lo scanner,
potete ottenere le coordinate dalle indicazioni della mappa stessa. Usando queste semplici
coordinate 0 GCPs (Ground Control Points) I’immagine viene deformata e adeguata al

sistema di coordinate che abbiamo scelto.



PROCEDIMENTO

Georeferenziare in QGIS significa in
molti casi utilizzare il plugin
‘Georeferencer GDAL’.

Si tratta di un plugin interno, cioe gia
residente nella vostra installazione.
Dovete soltanto attivarlo.

Andate sul menu Plugins > Gestisti e
Installa Plugins e attivate il plugin
Georeferenziatore Raster GDAL
nella scheda Installato . Per una
descrizione accurata del
funzionamento dei plugin andate
sulla pagina Usare i Plugins.

Plugins > Installed (30)
Search

Add Delimited Text Layer

| CadTools
— = Coordinate Capture

x DB Manager
Dxf2Shp Converter

s

# Google Maps Engine Connector
| [i4; GPS Tools
M GRASS
|| Group Stats
X  Heatmap
_ W1 mterpolation plugin
| % mmagis
| ¢ OffiineEditing
Orade Spatial GeoRaster
| £3 Point sampling tool
% I Processing
x QuickWKT
Raster Terrain Analysis plugin
|, Road graph plugin
%\ Spatial Query Plugin
| b sPmm

in: ® names  descripions | tags | authors

Georeferencer GDAL

Georeferencing rasters using GDAL

Category: Raster

Installed version: Version 3.1.9 (in
C:/0SGeo4W fapps/agis/plugins fgeorefplugin. dil)

Upgrade all | |uninstall plugn | | Reinstall plugin



http://www.qgistutorials.com/it/docs/using_plugins.html

PROCEDIMENTO

2. Ilplugin @ ora installato nel menu Raster. Fate click su Raster » Georeferencer » Georeferencer per aprire il plugin.

Pgnjedgdtﬂewgayermghmwl |DalahaﬂePrnaeﬂ1gHeb

e EROR (A e AR ee- - R
¥ J B SR x> =

@ Conversion

- - - - - -

GdalTools settings
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PROCEDIMENTO

3. La Finestra del plugin & suddivisa in 2 sezioni. La sezione in alto, quella dove il raster verra visualizzato e quella in basso, dove
verra visualizzata una scheda con il vostro GCP. Che potrebbe essere tradotto in italiano con “Punto di Controllo al Suolo”.
N.d.T.

Fie Edit View Settings Help

> %8 D PO NP LL QB fo -

GCP table (&) x)




PROCEDIMENTO

4. Ora apriremo la nostra immagine JPG. Andate su File - Apri Raster. Individuate l'immagine della carta geografica che avete

appena salvato e fate click su Apri.

BEPE3E O P2 L0 248 et flo »




PROCEDIMENTO

5. Nella schermata successiva vi verra chiesto di scegliere il sistema di riferimento delle coordinate (SR). Si tratta di specificare la
proiezione e il datum dei vostri punti di controllo. Qualora aveste raccolto i vostri punti usando un dispositivo GPS, sarebbe
stato necessario usare un CRS WGS84. Visto che invece state geo-referenziando una carta geografica digitalizzata allo scanner,
potete individuare il sistema di riferimento cercandolo nella mappa stessa. Esaminando la nostra immagine vediamo intanto
che le coordinate sono in Latidudine/Longitudine. Non sono Fornite informazioni specifiche riguardo il datum e dunque
tocchera a noi individuarne uno adeguato. Visto che si tratta dell'India e che la mappa é piuttosto antica, possiamo ipotizzare

che il datum Everest 1830 sia quello che Fa al caso nosktro.

Define this layer's coordinate reference systems:

This layer appears to have no projection specification. By default, this layer will now have its
projection set to that of the project, but you may override this by selecting a different projection
below.

Filter  evere

Recently used coordinate reference systems

Coordinate Reference System IAuthority D
(<] e
Coordinate reference systems of the world Hide deprecated CRSs

ln_.md*

Unknown datum based upon the Everest 1830 (1962 Definition)... EPSG:4044

1 ko datar mmm}nidun;m EPSG=01G veE
- Unknown datum based upon the Everest 1830 (1975 Definition)... EPSG:4045 |
~ Unknown datum based upon the Everest 1830 Modified ellipsoid EPSG:4018

4] | a|r

Selected CRS: | Unknown datum based upon the Everest 1830 (1962 Definition) elipsoid

+proj=longlat +a=6377301.243 +b=6356100.230165384 +no_defs



PROCEDIMENTO

6. A questo punto vedrete 'immagine caricata nella sezione in alto.

File Edit View Settings Help

e » Qh’:’@ 3E)3% *% @;@ﬁp;{u&wq o »




PROCEDIMENTO

7. Potete utilizzare lo strumento zoom (ingrandisci) e lo strumento pan (sposta) nella barra degli strumenti per esplorare meglio
la carta.

VFleEdt\ﬁewSetﬁ\gsHeb

| » LE|>8 %8 @ 3G 5% %6

|'|'l’ansfum:Notset|| 795,-179 lNone




PROCEDIMENTO

8. Adesso dobbiamo assegnare le coordinate ad alcuni punti di questa mappa. Se ingrandite a sufficienza potrete vedere le
coordinate della griglia con i relativi contrassegni. Usando la griglia potete determinare le coordinate X e Y nei punti in cui la
griglia fa un’intersezione. Fate click su Aggiungi punto nella barra degli strumenti.

&
 File Edit View Settngs Help

|'ﬁ’8\sﬁrm:Not§t| 473,-218 |None|



PROCEDIMENTO

9. Nella finestra di pop-up aggiungete le coordinate ricordando che X = longitudine e Y = latitudine. Fate click su OK.

Enter X and Y coordinates (DMS (dd mm ss.ss), DD (dd.dd) or projected coordinates
{mmmm.mm)) which correspond with the selected point on the image. Alternatively, dick the
button with icon of a pencil and then dick a corresponding point on map canvas of QGIS to fill
in coordinates of that point.

X /East: | 70 Y [North: |15
|| Snap to background layers

oK |./Frunmq1mva= Cancel |




PROCEDIMENTO

10. Noterete adesso che la tabella GCP ha una riga con i dettagli del vostro primo GCP.
{4
File Edit View Settings Help
> 5% @ PO DAL RML v~ fio »

3 e

. on/off id sreX
{‘ ” 0 416.76




PROCEDIMENTO

11. In modo del tutto analogo aggiungete almeno 4 GCPs per coprire l'intera immagine. Tanto pit numerosi saranno i punti di
controllo al suolo che registrerete tanto piti accurata sara la riproiezione dell'immagine sul sistema di coordinate che abbiamo
scelto.

File Edit View Settings Help

% > 62655 D PENE DL PO QM e -

residual [pixels]

0.00 0.00
0.00 0.00
0.00 0.00
0.00 0.00
0.00 0.00

|Tra'sfonn: Not set || 5704,-2765 I None




PROCEDIMENTO

12. Una volta che avete individuato un numero sufficiente di punti andate su Preferenze -> Impostazioni di Trasformmazione.

residual[pixels]
-895.21 5 X . 2 0.00

910.74 3 0.00
-2431.93 5 X 2 . 0.00
-2435.80
-2446.69 A 2 2 X 0.00

Not set | 976,0 | None




PROCEDIMENTO

13. Nella finestra di dialogo Impostazioni di trasformazione , scegliete nella casella Tipo di trasformazione il tipo Thin Plate Spline e
poi chiamate il vostro raster in uscita con il nome di 1870_southern_india_modified.tif. Scegliete EPSG:4326 come SR di
destinazione in modo che l'immagine risultante sia collocata in un datum ampiamente compatibile. Assicuratevi che 'opzione
Carica in QGIS una volta eseguito sia spuntata.

Transformation type: Thin Plate Spline

Compression: NONE
[] Create world file

Output raster: sersfujaval /[Downloads/1870_southern-india_modified. tif ‘

Target SRS: | EPSG:4326

Generate pdf map:

Qe

Generate pdf report:

| SetTarget Resolution

Horizontal | 1.00000

vertical | -1.00000

|| Use 0 for transparency when needed




PROCEDIMENTO

14. Tornate sulla finestra di georeferenziazione, andate su File » Inizia georeferenziazione. Questo dara inizio al processo di
deformazione dell'immagine usando i punti di controllo al suolo e quindi alla creazione del raster che georeferenziato che
volevamo ottenere.

File | Edit View Settings Help

s Aesles et | O L PP QA et fo »
- -— —w

T

| g3 Generate GDAL script trl+C

|
#% Load GCP points Ctri+L
#% Save GCP points as... Ctri+s !

Quit Ctrl+Q

&I
onfoff id sreX srcY d | residual [pixels]
® 0 416.76 -895.21 70.00 15.00 -0.00 0.00 0.00
® 1 2664.89 -910.74 85.00 15.00 -0.00 0.00 0.00
® 2 381.64 | -2431.93 70.00 5.00 -0.00 0.00 0.00
® 3 3454.12| -2435.80 S0.00 5.00 -0.00 0.00 0.00
® 4 1919.70 | -2446.69 80.00 5.00 -0.00 0.00 0.00

Start georeferencing I‘n'a'sform: Thin plate spline (TPS) Mean error: 1.26822e-11 ” -1198,-21 ” None I



PROCEDIMENTO

15. Una volta che il processo & concluso vedrete il layer georeferenziato in QGIS.

Vector Raster Database Processing Help

Edit Settings  Plugins
DPEHRLR RO PP LPRPLLLES e - B-
4 ARG H =mgEeRgw %

(]| coordinate: || 67.25,16.21 || scale || 1:18325850 ~ 3;][8: Render || ersc:432s |[@)][4)]




PROCEDIMENTO

16. La georeferenziazione a questo punto & stata completa. Ma, come sempre, &€ buona pratica verificare la bonta del nostro lavoro.
Come possiamo verificare che la nostra georeferenziazione sia sufficientemente accurata ? In questo caso, possiamo caricare i
confini amministrativi del paese da una fonte certa come il dataset di Natural Earth e confrontare con essa i nostri risultati.
Noterete che le due mappe si sovrappongono piuttosto bene. Ci sono alcuni errori che potrebbero essere ridotti prendendo un
numero maggiore di punti di controllo, cambiando i parametri di trasformazione oppure provando con un diverso tipo di datum.

Database Processing Help
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